Page not found
Incident Report for Efficient Learning
Resolved
This incident has been resolved.
Posted Jan 08, 2023 - 14:37 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 08, 2023 - 11:01 EST
Investigating
We are currently investigating this issue.
Posted Jan 08, 2023 - 09:26 EST
This incident affected: WEL Self-Study Platform (app.efficientlearning.com) and WEL Institutional Platform (wel.instructure.com).