Service Interruption-Login
Incident Report for Efficient Learning
Resolved
This incident has been resolved.
Posted Sep 26, 2020 - 16:30 EDT
Identified
We are currently working to resolve a service interruption which is limiting users ability to login to Wiley Efficient Learning. Please check status.efficientlearning.com for updates.
Posted Sep 26, 2020 - 11:02 EDT
This incident affected: WEL Self-Study Platform (app.efficientlearning.com) and WEL Institutional Platform (wel.instructure.com).