Service Interruption
Incident Report for Efficient Learning
Resolved
This incident has been resolved.
Posted May 03, 2018 - 01:27 EDT
Update
We apologize for the issue you are experiencing with the Wiley Efficient Learning platform. The root cause of the issue has been identified as a maintenance process which was running on our servers. We are in the process of implementing a solution and we expect to provide you with an update on resolution time ASAP.
Posted May 02, 2018 - 17:05 EDT
Identified
Due to an unforeseen technical error all Wiley Efficient Learning products are currently offline. We will confirm when this is issue is resolved. Thank you for your patience.
Posted May 02, 2018 - 09:26 EDT
This incident affected: WEL Self-Study Platform (app.efficientlearning.com) and WEL Institutional Platform (wel.instructure.com).