Service Alert
Incident Report for Efficient Learning
Resolved
Course pages are back up and running. If you still receive an error please clear your browsers cache before trying to access your course again.
Posted Aug 12, 2021 - 13:00 EDT
Update
We apologize for the delay. We are continuing to work on restoring access as soon as possible.
Posted Aug 12, 2021 - 12:33 EDT
Update
We apologize for the delay. We are continuing to work on restoring access as soon as possible.
Posted Aug 12, 2021 - 12:00 EDT
Update
We apologize for the delay. We are continuing to work on restoring access as soon as possible.
Posted Aug 12, 2021 - 11:32 EDT
Update
We apologize for the delay. We are continuing to work on restoring access as soon as possible.
Posted Aug 12, 2021 - 10:58 EDT
Update
We have identified the root cause of the issue and are working to restore all services as soon as possible.
We'll post back once the issue is resolved.
Posted Aug 12, 2021 - 10:34 EDT
Identified
An issue is affecting course pages. We’re working to fix this as soon as possible. See our status page for updates.
Posted Aug 12, 2021 - 10:15 EDT
This incident affected: WEL Self-Study Platform (app.efficientlearning.com) and WEL Institutional Platform (wel.instructure.com).