Service Alert
Incident Report for Efficient Learning
Resolved
This incident has been resolved.
Posted Mar 21, 2022 - 12:31 EDT
Identified
We are experiencing intermittent issues with login. If you receive an error that your username and password are incorrect please check back with us in an hour. We appreciate your patience while we work to resolve this issue.
Posted Mar 21, 2022 - 12:23 EDT
This incident affected: WEL Self-Study Platform (app.efficientlearning.com).