Service Alert
Incident Report for Efficient Learning
Resolved
The previous service interruption has been resolved. All systems are working as expected at this time.
Posted Sep 15, 2018 - 13:29 EDT
Identified
Wiley Efficient Learning is currently experiencing a service interruption. We are working to restore service as quickly as possible. Please check back here for updates.
Posted Sep 15, 2018 - 12:26 EDT
This incident affected: WEL Self-Study Platform (app.efficientlearning.com).