Service Alert - Wiley Efficient Learning Outage
Incident Report for Efficient Learning
Resolved
This incident has been resolved.
Posted Feb 22, 2021 - 19:56 EST
Update
This incident has been resolved.
Posted Feb 22, 2021 - 19:56 EST
Identified
Please be advised that efficientlearning.com is unavailable at this time. We are working to restore access to this website and will post updates as they become available.
Posted Feb 22, 2021 - 18:43 EST
This incident affected: WEL Self-Study Platform (app.efficientlearning.com) and WEL Institutional Platform (wel.instructure.com).